Velo-CC - Detection issue – Incident details

Fortnite experiencing degraded performance

Detection issue

Resolved
Under maintenance
Started 6 months agoLasted about 2 hours

Affected

CHEATS

Under maintenance from 7:05 PM to 8:44 PM

Fortnite

Under maintenance from 7:05 PM to 8:44 PM

Updates
  • Resolved
    Resolved

    UPDATED, Please Redownload from the site!

  • Investigating
    Investigating

    We are currently investigating this incident. DO NOT USE