Velo-CC - Updating to the newest version – Incident details

Fortnite experiencing degraded performance

Updating to the newest version

Resolved
Under maintenance
Started 2 months agoLasted 35 minutes

Affected

CHEATS

Under maintenance from 12:36 PM to 1:11 PM

Fortnite

Under maintenance from 12:36 PM to 1:11 PM

Updates
  • Resolved
    Resolved

    Updated to the new Fortnite Update and working again!

  • Identified
    Identified

    We are continuing to work on it.