Velo-CC - SERVER FIX – Incident details

Fortnite experiencing degraded performance

SERVER FIX

Resolved
Operational
Started about 2 months agoLasted less than a minute

Affected

CHEATS

Operational from 10:52 PM to 10:52 PM

Fortnite - Internal

Operational from 10:52 PM to 10:52 PM

Updates
  • Update
    Update

    (Compensated all licenses 16 hours for the downtime)

  • Resolved
    Resolved

    Servers should be up and stable from here on out, we will continue to monitor everything throughout the day. We appreciate the patience and hope to continue without issues, enjoy.